【FOJ1914】Funny Positive Sequence(单调队列)

题目链接

There are n integers a 1,a 2,…,a n-1,a n in the sequence A, the sum of these n integers is larger than zero. There are n integers b 1,b 2,…,b n-1,b n in the sequence B, B is the generating sequence of A and bi = a 1+a 2,+…+a i (1≤i≤n). If the elements of B are all positive, A is called as a positive sequence.

We left shift the sequence A 0,1,2,…,n-1 times, and get n sequences, that is showed as follows:

A(0): a1,a2,…,an-1,an

A(1): a2,a3,…,an,a1

A(n-2): an-1,an,…,an-3,an-2

A(n-1): an,a1,…,an-2,an-1

Your task is to find out the number of positive sequences in the set { A(0), A(1), …, A(n-2), A(n-1) }.

Input

The first line of the input contains an integer T (T <= 20), indicating the number of cases. Each case begins with a line containing one integer n (1 <= n <= 500,000), the number of elements in the sequence. The next line contains n integers ai(-2,000,000,000≤ai≤2,000,000,000,1≤i≤n), the value of elements in the sequence.

Output

For each test case, print a line containing the test case number (beginning with 1) and the number of positive sequences.

Sample Input

2
3
1 1 -1
8
1 1 1 -1 1 1 1 -1

Sample Output

Case 1: 1
Case 2: 4

解题思路:

考虑到n比较大暴力肯定是会超时的,因为A(0)-A(n-1)的关系,将数组先复制一倍作前缀和。然后只要用单调队列维护每一个区间的sum的最小值,当j>=n时,只要单调队列的head(队列最小值)-前面n-1项大于0即可。比如在判断a3,a4,a5...an,a(n+1),a(n+2)是否满足的时候,只需看queue[head] - sum[2]是否大于0即可,因为这里每个数只要减去sum[2]就是这一个区间每个数的前缀和,而当最小的前缀和都大于0时,说明整个区间的前缀和都是大于0的。

代码:

#include<cstdio>
#include<cstring>
typedef long long LL;
#define maxn 1000005
using namespace std;
LL q[maxn],sum[maxn],a[maxn];
int main()
{
    int T,k=1;
    scanf("%d",&T);
    while(T--)
    {
        int n,ans=0;
        scanf("%d",&n);
        memset(q,0,sizeof(q));
        memset(sum,0,sizeof(sum));
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        for(int i=n+1;i<=2*n;i++)
            sum[i]=sum[i-1]+a[i-n];
        int head=0,rear=0;
        for(int i=1;i<=2*n-1;i++)
        {
            while(rear>head && q[rear-1]>sum[i])rear--;
            q[rear++]=sum[i];
            if(i>=n)
            {
                if(q[head]-sum[i-n]>0)ans++;
                if(q[head]==sum[i-n+1])head++;
            }
        }
        printf("Case %d: %d\n",k++,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/81587619