hdu 1223 还是畅通工程

【思路】贪心求最短路,开始都是孤立点,优先选择路短建路

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。 
当N为0时,输入结束,该用例不被处理。 

Output

对每个测试用例,在1行里输出最小的公路总长度。 

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5

​​

Select Code

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int pre[10000],n,ans;
struct rode{
	int a,b,c;
}p[10000];
bool cmp(rode x,rode y){
	return x.c <y.c ;
}
int find(int x){
	int r=x;
	while(pre[r]!=r)
	r=pre[r];
	return r;
}
void join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy){
	pre[fx]=fy;
	}
	
}

int main(){
	while(~scanf("%d",&n)&&n){
		ans=0;
		for(int i=1;i<=n*(n-1)/2;++i){
			pre[i]=i;
			scanf("%d%d%d",&p[i].a ,&p[i].b ,&p[i].c );
		}
		sort(p+1,p+n*(n-1)/2+1,cmp);
		for(int i=1;i<=n*(n-1)/2;++i){
			int fx=find(p[i].a ),fy=find(p[i].b );
			if(fx!=fy){
			pre[fx]=fy;
			ans+=p[i].c;	
			}	
		}
	printf("%d\n",ans);	
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_42382758/article/details/81711567