candy(组合数 期望 log)

Problem Description

LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?

Input

There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.

Output

For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.

Sample Input

 

10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000

Sample Output

 

Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000

Source

2012 Asia Chengdu Regional Contest

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6408 6407 6406 6405 6404 

设第一个盒子吃完发现第二个盒子还有i个概率为f(i),一共吃了2n-i个,有n个是第一个盒子的,n-1个是第二个盒子的,推出公式

C(n,2*n-i)P^(n+1)(1-P)^(n-i).,注意第一个盒子打开了n+1次,得出第i次打开盒子1没糖的概率C(2n-i,n)p^(n+1)(1-p)^(n-i),得出第i次打开盒子2没糖的概率C(2n-i,n)(1-p)^(n+1)p^(n-i),第i次打开盒子没有糖的概率就为上述两式相加,根据期望公式每次与i相乘求和则为总期望

还有一个点,为防止溢出,这题用log处理

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=2*1e5+5;
typedef long double LD;
LD f[2*maxn];
LD logc(int n,int m)
{
   return  f[n]-f[m]-f[n-m];
}
int main()
{
    for(int i=1;i<=4*1e5;i++)
    f[i]=f[i-1]+log(i);
    int n;
    int t=0;
    double p;
    while(~scanf("%d%lf",&n,&p))
    {double ans=0.0;
    t++;
        for(int i=1;i<=n;i++)
        {
            LD c=logc(2*n-i,n);
            LD v1=c+(n+1)*log(p)+(n-i)*log(1-p);
            LD v2=c+(n+1)*log(1-p)+(n-i)*log(p);
            ans+=i*(exp(v1)+exp(v2));
        }
        printf("Case %d: %0.6lf\n",t,ans);
    }
  return 0;
}


 

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81713007
log