poj1961 Period(kmp)

Period

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input

3
aaa
12
aabaabaabaab
0
Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:如果一个字符串S是由一个字符串T重复K次形成的,则T为S的循环元。使K最大的字符串T为S的最小循环元,此时K称为最大循环次数。给定一个字符串S,求S的每个前缀的最大循环次数,若最大循环次数大于1,输出此时前缀长度和最大循环次数。

分析:根据kmp中next数组的定义,显然当i%(i - next[i])=0时,1~i-next[i]就是前缀i的最小循环元,解决问题。

代码

#include <cstdio>
#include <string>
#include <cstring>
#define N 1000005
using namespace std;

char s[N];
int next[N],n;

int main()
{
    int cnt = 0;
    while(~scanf("%d", &n))
    {
        if (!n) break;
        scanf("%s", s+1);
        printf("Test case #%d\n", ++cnt);
        int k = 0;
        for (int i = 2; i <= n; i++)
        {
            while(k && s[k + 1] != s[i]) k = next[k];
            if (s[k + 1] == s[i]) k++;
            next[i] = k;
            if (i - k == 0) continue;
            if (i % (i - k) == 0 && k) printf("%d %d\n", i, i / (i - k));
        }
        printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/zhanghaoxian1/article/details/81744013