E - 问世间哪有更完美 HDU - 6318 逆序数 树状数组+离散化

E - 问世间哪有更完美

 HDU - 6318 

Long long ago, there was an integer sequence a. 
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence. 
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements. 
What is the minimum amount of money you need to spend? 
The definition of inversion in this problem is pair (i,j)(i,j) which 1≤i<j≤n1≤i<j≤n and ai>ajai>aj.

Input

There are multiple test cases, please read till the end of input file. 
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence. 
In the second line, n integers separated by spaces, representing the orginal sequence a. 
1≤n,x,y≤1000001≤n,x,y≤100000, numbers in the sequence are in [−109,109][−109,109]. There're 10 test cases.

Output

For every test case, a single integer representing minimum money to pay.

Sample Input

3 233 666
1 2 3
3 1 666
3 2 1

Sample Output

0
3

题意:给定数列A,每次交换相邻两数要花费y,经过若干次交换操作后,若数列还不是升序,那么有一对不是升序就要罚x(例如最后变成  2,3,4,1  此时要罚3x  )

思路:求逆序数,输出min(x,y)*逆序数。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <malloc.h>
#define Twhile() int T;scanf("%d",&T);while(T--)
#define clc(a,b,n) for(int i=0;i<=n;i++)a[i]=b
#define clc2(a,b,n,m) for(int i=0;i<=n;i++)for(int j=0;j<=m;j++)a[i][j]=b
#define fora(i,a,b) for(int i=a;i<b;i++)
#define fors(i,a,b) for(int i=a;i>b;i--)
#define fora2(i,a,b) for(int i=a;i<=b;i++)
#define fors2(i,a,b) for(int i=a;i>=b;i--)
#define PI acos(-1.0)
#define eps 1e-6
#define INF 0x3f3f3f3f
#define BASE 131
#define lowbit(x) x&(-x)

typedef long long LL;
typedef long double LD;
typedef unsigned long long ULL;
using namespace std;
const int maxn=100000+11;
int tre[maxn];
int a[maxn],b[maxn];

void update(int i,int val,int n)//n是树的大小
{
    for(;i<=n;i+=lowbit(i))
        tre[i]+=val;
}
int sum(int i)
{
    int ret=0;
    for(;i>0;i-=lowbit(i))
        ret+=tre[i];
    return ret;
}
int main()
{
    int N,X,Y;
    while(~scanf("%d%d%d",&N,&X,&Y))
    {
        memset(tre,0,sizeof(tre));
        fora2(i,1,N){scanf("%d",a+i);b[i]=a[i];}
        sort(b+1,b+1+N);
        LL ans=0;
        fora2(i,1,N)
        {
            int k=lower_bound(b+1,b+1+N,a[i])-b;
            int tem=sum(k);
            tem=i-tem-1;
            ans+=tem;
            update(k,1,maxn-1);
        }
        printf("%lld\n",ans*min(X,Y));

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liyang__abc/article/details/81810652