【HDU - 4609 】3-idiots(FFT)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Coldfresh/article/details/81504409

King OMeGa catched three men who had been streaking in the street. Looking as idiots though, the three men insisted that it was a kind of performance art, and begged the king to free them. Out of hatred to the real idiots, the king wanted to check if they were lying. The three men were sent to the king’s forest, and each of them was asked to pick a branch one after another. If the three branches they bring back can form a triangle, their math ability would save them. Otherwise, they would be sent into jail.
However, the three men were exactly idiots, and what they would do is only to pick the branches randomly. Certainly, they couldn’t pick the same branch - but the one with the same length as another is available. Given the lengths of all branches in the forest, determine the probability that they would be saved.
Input
An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
Each test case begins with the number of branches N(3≤N≤10 5).
The following line contains N integers a_i (1≤a_i≤10 5), which denotes the length of each branch, respectively.
Output
Output the probability that their branches can form a triangle, in accuracy of 7 decimal places.
Sample Input
2
4
1 3 3 4
4
2 3 3 4
Sample Output
0.5000000
1.0000000

感觉这题还是比较恶心。我们先求出两两组合的所有可能的种数,如果木棒的大小在10的三次方的话,其实是可以利用生产函数来模拟的,但是范围有10的5次,那就用FFT来模拟生成函数的卷积和啊。
代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define maxx 100005
using namespace std;
const double PI=acos(-1.0);
struct Complex
{
    double x,y;
    Complex(double _x=0,double _y=0)
    {
        x=_x,y=_y;
    }
    Complex operator-(const Complex &b)const
    {
        return Complex(x-b.x,y-b.y);
    }
    Complex operator+(const Complex &b)const
    {
        return Complex(x+b.x,y+b.y);
    }
    Complex operator*(const Complex &b)const
    {
        return Complex(x*b.x-y*b.y,x*b.y+y*b.x);
    }
};
void change(Complex y[],int len)
{
    for(int i=1,j=len>>1;i<len-1;i++)
    {
        if(i<j)swap(y[i],y[j]);
        int k=len>>1;
        while(j>=k)
        {
            j-=k;
            k/=2;
        }
        if(j<k)j+=k;
    }
}
void fft(Complex y[],int len ,int on)
{
    change(y,len);
    for(int h=2;h<=len;h<<=1)
    {
        Complex wn(cos(-on*2*PI/h),sin(-on*2*PI/h));
        for(int j=0;j<len;j+=h)
        {
            Complex w(1.0);
            for(int k=j;k<j+h/2;k++)
            {
                Complex u=y[k];
                Complex t=w*y[k+h/2];
                y[k]=u+t;
                y[k+h/2]=u-t;
                w=w*wn;
            }
        }
    }
    if(on==-1) for(int i=0;i<len;i++)
        y[i].x/=len;
}
long long num[maxx<<2];
int a[maxx];
void init()
{
    memset(num,0,sizeof(num));
}
Complex _x[maxx<<2];
long long sum[maxx<<2];
int n;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        init();
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",a+i);
            num[a[i]]++;
        }
        sort(a+1,a+n+1);
        int _len=a[n]+1;
        int len=1;
        while(len<2*_len)len<<=1;
        for(int i=0;i<_len;i++)_x[i]=Complex(num[i],0);
        for(int i=_len;i<len;i++) _x[i]=Complex(0,0);
        fft(_x,len,1);
        for(int i=0;i<len;i++) _x[i]=_x[i]*_x[i];
        fft(_x,len,-1);
        for(int i=0;i<len;i++)num[i]=(long long)(_x[i].x+0.5);
        len=_len*2-1;

        for(int i=1;i<=n;i++) num[a[i]+a[i]]--;
        for(int i=0;i<len;i++)num[i]/=2;

        len=a[n]*2;
        for(int i=1;i<=len;i++)
            sum[i]=sum[i-1]+num[i];
        //for(int i=0;i<=len;i++)cout<<sum[i]<<" ";
        //cout<<endl;
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            ans+=sum[len]-sum[a[i]];
            ans-=(long long)(n-i)*(i-1);
            ans-=n-1;
            ans-=(long long)(n-i)*(n-i-1)/2;
        }
        //cout<<ans<<endl;
        long long total=(long long)n*(n-1)*(n-2)/6;
        printf("%.7lf\n",ans*1.0/total);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Coldfresh/article/details/81504409