暑假集训day9——树结构练习——排序二叉树的中序遍历

树结构练习——排序二叉树的中序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。

Input

输入包含多组数据,每组数据格式如下。

第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)

第二行包含n个整数,保证每个整数在int范围之内。

Output

为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。

Sample Input

1
2
2
1 20

Sample Output

2
1 20

Hint

Source

赵利强

/*本题由于空格问题,调试了好长时间,还要注意此时data应该是Int型>_<*/

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
    int data;
    struct node *l, *r;
};

char s[100], s1[100];
int len, len1, k;

struct node *creat(struct node *root, int x)
{
    if(!root)
    {
        root = (struct node*)malloc(sizeof(struct node));
        root-> data = x;

        root-> l = NULL;
        root-> r = NULL;
    }

    else
    {
        if(root-> data > x)
        {
            root-> l = creat(root-> l, x);
        }

        else
        {
            root-> r = creat(root-> r, x);
        }
    }

    return root;
}

void mid(struct node *root)
{

    if(root)
    {
        mid(root-> l);
       // printf("%d\n", i);
        if(!k)
        {
            printf("%d", root-> data);
            k++;
        }

        else
        {
            printf(" %d", root-> data);
        }
        mid(root-> r);
    }
}

int main(void)
{
    int x, n, i;
    struct node *root;

    while(~scanf("%d", &n))
    {
        root = NULL;
        k = 0;
        for(i = 0; i < n; i++)
        {
            scanf("%d", &x);
            root = creat(root, x);
        }
        mid(root);
        printf("\n");
    }

    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/Eider1998/article/details/81531991