11----数值过大的加数和问题

A + B Problem
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cstring>
#include<iomanip>
#include<math.h>
using namespace std;
char s[1005],a[1005],b[1005];
int main()
{
    int n,m,p;
    scanf("%d",&n);
getchar();
    for(int i=1; i<=n; i++)
    {
        for(int j=0; j<1005; j++)
            s[j]='0';
        for(int j=0; j<1005; j++)
            a[j]='0';
        for(int j=0; j<1005; j++)
            b[j]='0';
scanf("%s %s",a,b);
m=strlen(a);
for(int j=0,k=m-1;m>=0;j++,m--)
    s[j]=a[k];
m=strlen(b);
for(int j=0,k=m-1;m>=0;j++,m--)
{
    s[j]=s[j]-'0'+b[k];
    p=j;
    while(s[p]>'9')
    {
        s[p]=s[p]-10;
        s[p+1]=s[p+1]+1;
        p++;
    }
}
s[p+1]='\0';
printf("Case %d:\n",i);
printf("%s+%s=",a,b);
for(int j=strlen(s)-1;j>=0;j--)
    printf("%c",s[j]);
printf("\n");
    }
    return 0;
}

对于数值位数过多的和问题,采用普通方法已经不能满足需要
对于学过Java的同学来讲比较简单,同样也可用C来解决
通过字符数组来做进行数组位的相加;思想比较简单,就不做过多解释了

猜你喜欢

转载自blog.csdn.net/Nacht_one/article/details/82117185