Farey Sequence

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

典型的欧拉函数问题,你在打表的时候最后累加打表一下,就行了。

#include<stdio.h>
#include<string.h>
#define N 1000010
long long int a[N];
void cn()
{
    a[1]=1;
    for(int i=2; i<N; i++)
        a[i]=i;
    for(int i=2; i<N; i++)
        if(a[i]==i)
            for(int j=i; j<N; j+=i)
                a[j]=a[j]/i*(i-1);
    for(int i=3; i<N; i++)
        a[i]+=a[i-1];
}
int main()
{
    cn();
    int z;
    while(~scanf("%d",&z)&&z)
    {
        printf("%lld\n",a[z]);
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/aini875/article/details/82151814