POJ - 2478 Farey Sequence (欧拉函数

版权声明:欢迎加好友讨论~ QQ1336347798 https://blog.csdn.net/henu_xujiu/article/details/81486814

题目链接


The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

 欧拉函数模板套用

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define ll long long 
#define Max 1000005
ll  euler[Max],ans[Max];
void eulerr(){
     euler[1]=1;
     for(int i=2;i<Max;i++)
       euler[i]=i;
     for(int i=2;i<Max;i++)
        if(euler[i]==i)
           for(int j=i;j<Max;j+=i)
              euler[j]=euler[j]/i*(i-1);//先进行除法是为了防止中间数据的溢出
}
int main()
{
	eulerr();
	ans[1]=0;
	for(int i=2;i<1000005;i++)
		ans[i]=ans[i-1]+euler[i];
	int n;
	while(cin>>n){
		if(n==0)break;
		cout<<ans[n]<<endl;
}}
	
	

	

猜你喜欢

转载自blog.csdn.net/henu_xujiu/article/details/81486814