HDU-3635-Dragon Balls(并查集)

                                                        Dragon Balls


Problem Description

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

题意描述:

有n个龙珠,在1到n个城市中,T a b 移动a所在城市的所有龙珠到b所在的城市,Q a 输出a所在的城市,城市的龙珠数量,a移动的次数

程序代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[10010],num[10010],book[10010],n,m;
int getf(int u);
void merge(int u,int v);
int main()
{
	char s;
	int T,i,j,k,u,v,t,count=1;
	scanf("%d",&T);
	while(T--)
	{
		printf("Case %d:\n",count++);
		memset(book,0,sizeof(book));
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		{
			f[i]=i;
			num[i]=1;
		}
		while(m--)
		{
			scanf(" %c",&s);
			if(s=='T')
			{
				scanf("%d%d",&u,&v);
				merge(u,v);
			}
			else
			{
				scanf("%d",&t);
				k=getf(t);
				printf("%d %d %d\n",k,num[k],book[t]);	
			}	
		}
	}
	return 0;
}
int getf(int u)
{
    int t;
	if(u==f[u])
		return u;
	t=f[u];
	f[u]=getf(f[u]);
	book[u]+=book[t];
	return f[u];
}
void merge(int u,int v)
{
	u=getf(u);
	v=getf(v);
	if(u!=v)
	{
		f[u]=v;
		num[v]+=num[u];
		num[u]=0;
		book[u]++;
	}
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/81455039