HDU3635——Dragon Balls 【并查集】

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

题目大意:给你两种操作,T把第A个龙珠所在的城市的所有龙珠转移到第B个龙珠所在的城市,Q问第A个龙珠在哪一个城市,这个城市有多少颗龙珠,这个龙珠转移了多少次。

大致思路:这道题根据题意可以想到用并查集去写,首先我们可以定义一个数组用来记录每一个城市的龙珠数量,每一次状态压缩的过程中都要更新一次他的值,然后在用一个数组用来记录每一个龙珠的转移次数。我们知道每一转移当前节点,其根节点只用转移一次,主要是其父节点的转移,我们可以知道一个龙珠的转移次数=其根节点+父节点。

Talk is cheap,show me the code.废话少说,放码过来。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int MAXN=1000010;
int pre[MAXN],num[MAXN],ran[MAXN];
void init(int n){
	for(int i=1;i<=n;i++){
		pre[i]=i;
		num[i]=0;
		ran[i]=1;
	}
}
int find(int x){
	if(x==pre[x]) return x;
	int t=pre[x];
	pre[x]=find(pre[x]);
	num[x]=num[x]+num[t];//一个球的移动次数等于球本身移动次数加上父节点的移动次数
	return pre[x];
}
void join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy){
		pre[fx]=fy;
		num[fx]=1;//头结点要移动一次
		ran[fy]=ran[fx]+ran[fy];//把当前城市的球转移到下一个城市
	}
}
int main(){
	int t;
	scanf("%d",&t);
	int kase=0;
	while(t--){
		int n,q;
		scanf("%d%d",&n,&q);
		getchar();
		init(n);
		printf("Case %d:\n",++kase);
		while(q--){
			char s;
			int a,b;
			scanf("%c",&s);
			if(s=='T'){
				scanf("%d%d",&a,&b);
				getchar();
				join(a,b);
			}
			else if(s=='Q'){
				scanf("%d",&a);
				getchar();
				int ans=find(a);
				printf("%d %d %d\n",ans,ran[ans],num[a]);
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/81713020