PAT Advanced 1147. Heaps (30)

问题描述:

1147. Heaps (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 100), the number of trees to be tested; and N (1 < N <= 1000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line "Max Heap" if it is a max heap, or "Min Heap" for a min heap, or "Not Heap" if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10


由于这些完全二叉树的后序遍历的顺序都是一样的,所以可以先把后序遍历的顺序记录在数组vo[]中,每次按照vo中记录的顺序输出即可。。。

AC代码:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
#include<bits/stdc++.h>
using namespace std;
vector<pair<int,int> > vt;
vector<int> vo;
void dfs(int n)
{
	if(vt[n].first!=-1)
	dfs(vt[n].first);
	if(vt[n].second!=-1)
	dfs(vt[n].second);
	vo.emplace_back(n);
}
int main()
{
  	ios::sync_with_stdio(false);
//	freopen("data.txt","r",stdin);
	int n,m,k,c1,c2,x;
	cin>>n>>m;
	vt.resize(m,make_pair(-1,-1));
	for(int i=0;i<vt.size();i++)
	{
		if(2*i+1<m)
		vt[i].first=2*i+1;
		if(2*i+2<m)
		vt[i].second=2*i+2;
	}
	dfs(0);
	for(;n--;)
	{
		vector<int> v;
		for(int mm=m;mm--;)
		{
			cin>>x;
			v.emplace_back(x);
		}
		
		int flag=0;
		for(int i=0;i<v.size();i++)
		{
			if(flag>0)
			{
				if((2*i+1<m&&v[i]<v[2*i+1])||(2*i+2<m&&v[i]<v[2*i+2]))
				{
					flag=0;
					break;
				}
			}
			else if(flag<0)
			{
				if((2*i+1<m&&v[i]>v[2*i+1])||(2*i+2<m&&v[i]>v[2*i+2]))
				{
					flag=0;
					break;
				}
			}
			else
			{
				if(2*i+1<m&&v[i]>v[2*i+1])
				flag=1;
				else if(2*i+1<m&&v[i]<v[2*i+1])
				flag=-1;
				
				if(flag<0&&2*i+2<m&&v[i]>v[2*i+2]||(flag>0&&2*i+2<m&&v[i]<v[2*i+2]))
				flag=0;
			}
		}
		
		if(flag>0)
		cout<<"Max Heap"<<endl;
		else if(flag<0)
		cout<<"Min Heap"<<endl;
		else
		cout<<"Not Heap"<<endl;
		
		cout<<v[vo[0]];
		for(int i=1;i<vo.size();i++)
		cout<<" "<<v[vo[i]];
		cout<<endl;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/baidu_37550206/article/details/79716955