1147 Heaps (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
#include<iostream>
#include<vector>
using namespace std;
int m, n;
int out_count;
struct node_tree
{
    node_tree * lchild;
    node_tree * rchild;
    int data;
};


node_tree * creat_tree(vector<int> &vec, int parent){
   
    if(parent >= vec.size()){
        
        return NULL;
    }
    node_tree * temp_tree = new node_tree;
    temp_tree -> data = vec[parent];
    temp_tree -> lchild = creat_tree(vec, parent * 2);
    temp_tree -> rchild = creat_tree(vec, parent * 2 + 1);
    
    
       
    return temp_tree;
}

void postorder(node_tree * &T){
    
    

    if(T != NULL){
        
        if(T -> lchild != NULL){
            postorder(T -> lchild);
        }
        if(T -> rchild != NULL){
            postorder(T -> rchild);
        }
        out_count++;
        printf("%d%s", T -> data, out_count == n ? "\n" : " ");
    }
    
    
    
        
    

}
int main(){

    
    cin >> m >> n;
    int first_child = n / 2 + 1;
    int last_child = n;

    for(int i = 0; i < m; i++){
        vector<int> vec(n + 1);
        for(int j = 1; j <= n; j++){

            
            scanf("%d", &vec[j]);

        }
        node_tree * T = new node_tree;
        
        T = creat_tree(vec, 1);
        int total_pos = 0, total_neg = 0, total_zero = 0;
        for(int j = first_child; j <= last_child; j++){
            int zero_cnt = 0, pos_cnt = 0, neg_cnt = 0;
            int temp = last_child;
            int count = 0;
            while (temp / 2)
            {
                count ++;
                if(vec[temp] - vec[temp / 2] > 0){
                    pos_cnt++;
                }
                if(vec[temp] - vec[temp / 2] == 0){
                    zero_cnt++;
                }
                if(vec[temp] - vec[temp / 2] < 0){
                    neg_cnt++;
                }
                temp /= 2;
            }

            if(pos_cnt == 0 && neg_cnt != 0){
                total_neg++;
            }
            if(pos_cnt != 0 && neg_cnt == 0){
                total_pos++;
            }
            if(zero_cnt ==count){
                total_zero++;
            }

            

        }
        out_count = 0;
        if(total_neg == 0 && total_pos != 0){

            printf("Min Heap\n");
            postorder(T);

        }else if(total_neg != 0 && total_pos == 0){

            printf("Max Heap\n");
            postorder(T);

        }else{

            printf("Not Heap\n");
            postorder(T);
            
        }

        

    }

    return 0;
}
发布了32 篇原创文章 · 获赞 0 · 访问量 433

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104077355