A1027 Colors in Mars (20)

1027 Colors in Mars (20)(20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input

15 43 71

Sample Output

#123456

思路:

         第一次用常规的进制转换,将转换好的值存进数组里面,在切刀char jz[]={'0','1',.....'C'};这个数组输出, 有点麻烦

         第二次直接将值用过char jz[];映射输出就行, 

总结:

       将十进制数y转换为Q进制数z

       

	if(y==0) printf("0");
	while(y!=0){
		z[num++]=y%Q;
		y/=Q;
	}
#include <cstdio>
int main(){
	int r,b,g;
	char jinzhi[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
		scanf("%d %d %d",&r,&g,&b);		
		printf("#");
			printf("%c%c",jinzhi[r/13],jinzhi[r%13]);
			printf("%c%c",jinzhi[g/13],jinzhi[g%13]); 
			printf("%c%c",jinzhi[b/13],jinzhi[b%13]); 
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40959340/article/details/81545390