//贪心+dp//最长下降子序列//Monkey and Banana------四G

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

解题思路:
因为每块砖有三种摆法(高和底面积不同),可以把这三种情况当成不同的三块砖,加入brick数组中。注意,一定要分清长和宽,长要比宽长,这样在后面dp的过程中可以保证长边和长边比较、短边和短边比较。
dp过程的思路我写在注释里了。

#include<stdio.h>
#include<algorithm>
using namespace std;

int dp[2000];

struct node
{
    int c,k,g;
}brick[2000];

bool cmp(node x,node y)
{
    if(x.c!=y.c)
        return x.c>y.c;
    else
        return x.k>y.k;
}

int maxx(int a,int b)
{
    if(a>b)
        return a;
    return b;
}

int main()
{
    int m,tmp[3],max,set=0,cnt;
    while(1)
    {
        scanf("%d",&m);
        if(m==0)
            return 0;
        cnt=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&tmp[0],&tmp[1],&tmp[2]);
            sort(tmp,tmp+3);
            brick[cnt].c=tmp[0];
            brick[cnt].k=tmp[1];
            brick[cnt++].g=tmp[2];
            brick[cnt].c=tmp[1];
            brick[cnt].k=tmp[2];
            brick[cnt++].g=tmp[0];
            brick[cnt].c=tmp[0];
            brick[cnt].k=tmp[2];
            brick[cnt++].g=tmp[1];
        }
        sort(brick,brick+cnt,cmp);
        max=0;
        for(int i=0;i<cnt;i++)//遍历所有砖块
        {
            dp[i]=brick[i].g;//dp[i]代表以第i块砖为顶的塔的最大高度
            //初始值是i砖块的高度(最坏的情况就是塔只有i一块砖)
            for(int j=i-1;j>=0;j--)//开始决定i砖块底下的砖是什么
            {
                if(brick[j].c>brick[i].c&&brick[j].k>brick[i].k)//如果j砖块符合条件
                {
                    dp[i]=maxx(dp[i],dp[j]+brick[i].g);
                    //放在以j砖块为顶的塔上是否比原来的值大
                }
            }
            if(dp[i]>max)//答案是所有dp中的最大值
                max=dp[i];
        }
        printf("Case %d: maximum height = %d\n",++set,max);
    }
}

猜你喜欢

转载自blog.csdn.net/lydia_ke/article/details/79370191