HDU-1069 Monkey and Banana (贪心+DP)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89392795

Monkey and Banana

 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1069

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:有n种积木,给出长宽高,积木可以翻转使用,问最多可以搭多高,上面的积木的长和宽要严格小于下面的

思路:每个积木有六种摆放方式,记录所有摆放方式的长宽高,对积木按照长宽的大小进行排序

dp [ i ] 为以第i个积木为最底层的最大高度

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
using namespace std;
const int N=200;
int dp[N];
struct node
{
    int x,y,z;
    node() {}
    node(int _x,int _y,int _z)
    {
        x=_x,y=_y,z=_z;
    }
} e[N];
bool cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    int n,t=1;
    while(~scanf("%d",&n)&&n)
    {
        int x,y,z,tot=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            e[tot++]=node(x,y,z);
            e[tot++]=node(x,z,y);
            e[tot++]=node(y,x,z);
            e[tot++]=node(y,z,x);
            e[tot++]=node(z,x,y);
            e[tot++]=node(z,y,x);
        }
        sort(e,e+tot,cmp);
        memset(dp,0,sizeof(dp));
        dp[0]=e[0].z;
        int maxx=0;
        for(int i=1; i<tot; i++)
        {
            maxx=0;
            for(int j=0; j<i; j++) //可以摆在第i个积木上的最大高度
                if(e[j].x<e[i].x&&e[j].y<e[i].y)
                    maxx=max(maxx,dp[j]);
            dp[i]=e[i].z+maxx;
        }
        int ans=0;
        for(int i=0;i<tot;i++)
            ans=max(ans,dp[i]);
        printf("Case %d: maximum height = %d\n",t++,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89392795