Girls and Boys (二分匹配—最大独立团)

     the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

    The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

    the number of students
    the description of each student, in the following format
    student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
    or
    student_identifier:(0)

    The student_identifier is an integer number between 0 and n-1, for n subjects.
    For each given data set, the program should write to standard output a line containing the result.
Input

    7
    0: (3) 4 5 6
    1: (2) 4 6
    2: (0)
    3: (0)
    4: (2) 0 1
    5: (1) 0
    6: (2) 0 1
    3
    0: (2) 1 2
    1: (1) 0
    2: (1) 0

Output

    5
    2

Sample Input

    7
    0: (3) 4 5 6
    1: (2) 4 6
    2: (0)
    3: (0)
    4: (2) 0 1
    5: (1) 0
    6: (2) 0 1
    3
    0: (2) 1 2
    1: (1) 0
    2: (1) 0

Sample Output

    5
    2

题意:让我们找出一个最大的集合使得该集合的任意两个人没有关系。

分析:最大独立团的问题:最大独立团 = 顶点数 - 最大匹配数

应注意的是该题没有给出哪些为男哪些为女,所以就把一人拆成两人来算,最终匹配的数目要除以二。

#include<stdio.h>
#include<string.h>
int e[510][510],match[510],book[510];
int n,m;
int dfs(int u)
{
	int i;
	for(i = 0; i < n; i ++)
	{
		if(book[i] == 0 && e[u][i] == 1)
		{
			book[i] = 1;
			if(match[i] == 0 || dfs(match[i]))
			{
				match[i] = u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,x,y,sum;
	while(scanf("%d",&n) != EOF)
	{
		sum = 0;
		memset(e,0,sizeof(e));
		memset(match,0,sizeof(match));
		for(i = 0; i < n; i ++)
		{
			scanf("%d: (%d)",&x,&m);
			for(j = 0; j < m; j ++)
			{
				scanf("%d",&y);
				e[x][y] = 1;
			}
		}
		for(i = 0; i < n; i ++)
		{
			for(j = 0; j < n; j ++)
				book[j] = 0;
			if(dfs(i))
				sum ++;
		}
		printf("%d\n",n-sum/2);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81538386