HDU1068 Girls and Boys【二分图 最大独立集】

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13947    Accepted Submission(s): 6564


 

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

 Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

Source

Southeastern Europe 2000

问题链接:HDU1068 Girls and Boys

问题描述:给定数字n,有n个人从0开始编号到n-1,接下去n行,第i行第一个数字为第i个人的编号,(m)表示有m个人与这个人配对,接下去输入这每个人的编号

解题思路:求最大独立集,但是这并不是两个集合,而是一个集合,所以求出最大匹配后需要/2,最大独立集=N-最大匹配。

AC的C++程序

#include<iostream>
#include<vector>
#include<cstring>

using namespace std;

const int N=100000;

vector<int>g[N];

bool vis[N];
int link[N];

bool find(int x)
{
	for(int i=0;i<g[x].size();i++)
	{
		int y=g[x][i];
		if(!vis[y])
		{
			vis[y]=true;
			if(link[y]==-1||find(link[y]))
			{
				link[y]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		  g[i].clear();
		for(int i=0;i<n;i++)
		{
			int a,b,num;
			scanf("%d: (%d)",&a,&num);
			while(num--)
			{
				scanf("%d",&b);
				g[a].push_back(b);
			}
		}
		memset(link,-1,sizeof(link));
		int cnt=0;//最大匹配数 
		for(int i=0;i<n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
			  cnt++;
		}
		printf("%d\n",n-cnt/2);//最大独立集 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/84675887