POJ - 2420 A Star not a Tree? (模拟退火)

版权声明:Why is everything so heavy? https://blog.csdn.net/lzc504603913/article/details/83116970

A Star not a Tree?

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9462   Accepted: 4070

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

Source

Waterloo Local 2002.01.26

[Submit]   [Go Back]   [Status]   [Discuss]

题意:给你N个点,让你在平面上选择一个点,使得这个点到所有点的距离和最短。

解题思路:模拟退火!网上很多代码其实是爬山但是却说成了退火。当然爬山也能过!具体看代码!

#include<bits/stdc++.h>
using namespace std;
const int MAXN=500005;
const double eps=1e-8;
const double V=0.98;
typedef long long ll;

int N;
double X[MAXN];
double Y[MAXN];
double dx[8]={-1,-1,0,1,1,1,0,-1};
double dy[8]={0,1,1,1,0,-1,-1,-1};

double dis(double x,double y){
    double ret=0;
    for(int i=1;i<=N;i++)
        ret+=sqrt((x-X[i])*(x-X[i])+(y-Y[i])*(y-Y[i]));
    return ret;
}

double rand01()
{
    double t1=(double)(rand()%1000)/(double)1000,
           t2=(double)(rand()%1000)/(double)1000;
    double r=t1+t2*0.001;
    return r;
}

double tuihuo(){
    double x=rand()%10000,y=rand()%10000;
    double ans=dis(x,y);
    double dt=sqrt(10000*10000*2);
    while(dt>eps){
        //八个方向尝试,实际上4个足够了。
        for(int i=0;i<8;i++){
            double nx=x+dx[i]*dt;
            double ny=y+dy[i]*dt;
            double d=dis(nx,ny);
            //如果更优,必然转移
            if(d<ans){
                x=nx;
                y=ny;
                ans=d;
            }
            else{
                //模拟退火核心操作,即使答案不是最优,也有一定概率转移
                if(exp(ans-d)/dt>rand01()){
                    x=nx;
                    y=ny;
                    ans=d;
                }
            }
        }
        dt*=V;//缩短步长
    }
    return ans;
}


int main(){


    scanf("%d",&N);
    for(int i=1;i<=N;i++)
        scanf("%lf%lf",&X[i],&Y[i]);

    printf("%.0lf\n",tuihuo());

    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc504603913/article/details/83116970