POJ 1065 Wooden Sticks(贪心 LIS思想)

版权声明:From: http://blog.csdn.net/tju_tahara https://blog.csdn.net/TJU_Tahara/article/details/77402313

Wooden Sticks
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 23823   Accepted: 10271

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

Source



题目大意:

给出好多个木棍,有l 和 w值, 切割时,如果这次的l 和 w 都小于上一次的,则切割时间位0, 否则为1. 问最小切割时间。


分析:

其实是很有意思的一道题。按一个属性排序是不用说的。拍完序后考虑另外一个属性,发现对于第i根木棍,你只要找比他大的一根木棍,在它之后进行切割就行了。想想实现,会发现正好是nlogn的LIS的实现方法。比较有趣。



#include <iostream>
#include <map>
#include <queue>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define MAX 5500

using std::sort;
using std::lower_bound;

struct node{
	int l, w;
}arr[MAX];

bool operator<(const node& a, const node& b){
	if(a.l == b.l) return a.w > b.w;
	return a.l > b.l;
}


int arrl[MAX];
int res[MAX], top;

int main()
{
	int casen, num, tmp, i;
	scanf("%d", &casen);
	while(casen--){
		scanf("%d", &num);
		for(i = 0; i < num; i++){
			scanf("%d%d", &arr[i].l, &arr[i].w);
		}
		
		sort(arr, arr + num);

		for(i = 0; i < num; i++)
			arrl[i] = arr[i].w;
		
		top = 0;

		for(i = 0; i < num; i++){
			tmp = lower_bound(res, res + top, arrl[i]) - res;
			if(tmp + 1 > top) top = tmp + 1;
			res[tmp] = arrl[i];
		}

		printf("%d\n", top);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/TJU_Tahara/article/details/77402313