hdu 1098 Ignatius's puzzle

题目:
Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5x13+13*x5+ka*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input
11
100
9999

Sample Output
22
no
43

题意:给定一个方程式f(x)=5x13+13*x5+kax,给定一个非负整数k,求能不能找到一个尽量小的非负整数a,使得上述方程式中的x任意取值,结果都能被65整除,如果有,输出a的值,否则输出no。
数学题:F(0)=0,能被65整除。f(1) = 18+ka,要是让f(1)也满足题目要求的条件,则18+6ka就能被65整除
假设18+6ka=i, a = (i
65-18)/k;利用循环,带入不同的i来求a。

代码:

//
//  main.cpp
//  hdu1098
//
//  Created by zhan_even on 2018/10/31.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    int k,a;
    while (cin>>k) {
        a = 0;
        for(int i=1;i<10000;i++){
            if ((i*65-18)%k == 0) {
                a = (i*65-18)/k;
                break;
            }
        }
        if (a==0) {
            cout<<"no"<<endl;
        }
        else
            cout<<a<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41568105/article/details/83719327