百练 4116 拯救行动

总时间限制: 

1000ms

内存限制: 

65536kB

描述

公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。 
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。 
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。

给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。

输入

第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入 
1、两个整数代表N和M, (N, M <= 200). 
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#"代表墙壁。

输出

扫描二维码关注公众号,回复: 4333151 查看本文章

如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible"

样例输入

2
7 8
#@#####@
#@a#@@r@
#@@#x@@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@ 
13 40
@x@@##x@#x@x#xxxx##@#x@x@@#x#@#x#@@x@#@x
xx###x@x#@@##xx@@@#@x@@#x@xxx@@#x@#x@@x@
#@x#@x#x#@@##@@x#@xx#xxx@@x##@@@#@x@@x@x
@##x@@@x#xx#@@#xxxx#@@x@x@#@x@@@x@#@#x@#
@#xxxxx##@@x##x@xxx@@#x@x####@@@x#x##@#@
#xxx#@#x##xxxx@@#xx@@@x@xxx#@#xxx@x#####
#x@xxxx#@x@@@@##@x#xx#xxx@#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#xx@##@#@##xx@#@@x@x
x#x#@x@#x#@##@xrx@x#xxxx@##x##xx#@#x@xx@
#x@@#@###x##x@x#@@#@@x@x@@xx@@@@##@@x@@x
x#xx@x###@xxx#@#x#@@###@#@##@x#@x@#@@#@@
#@#x@x#x#x###@x@@xxx####x@x##@x####xx#@x
#x#@x#x######@@#x@#xxxx#xx@@@#xx#x#####@

样例输出

13
7

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct Pos
{
    int x,y;
    int t;
    Pos(int a,int b,int c)
    {
        x = a;
        y = b;
        t = c;
    }
    Pos(){}
    bool operator < (const Pos &a) const
    {
        return t > a.t;
    }
};
Pos s,e,temp;
const int MAX = 220;
int M,N;
char Map[MAX][MAX];
int visited[MAX][MAX];
int l[MAX][MAX];
int dx[4] = {1,0,-1,0};
int dy[4] = {0,1,0,-1};
void BFS()
{
    priority_queue < Pos > q;
    q.push(s);
    while(!q.empty())
    {
        temp = q.top();
        q.pop();
        if((temp.x == e.x) && (temp.y == e.y))
        {
            printf("%d\n",temp.t);
            return;
        }
        for(int i = 0;i < 4; i++)
        {
            int tx = temp.x + dx[i];
            int ty = temp.y + dy[i];
            if(tx >= 0 && tx < N && ty >= 0 && ty < M && Map[tx][ty] != '#' && visited[tx][ty] == 0)
            {
                if(Map[tx][ty] == 'x')
                    q.push(Pos(tx,ty,temp.t + 2));
                else
                    q.push(Pos(tx,ty,temp.t + 1));
                visited[tx][ty] = 1;
            }
        }
    }
    printf("Impossible\n");
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&N,&M);
        memset(l,0,sizeof(l));
        memset(visited,0,sizeof(visited));
        for(int i = 0;i < N; i++)
        {
            getchar();
            for(int j = 0;j < M; j++)
            {
                scanf("%c",&Map[i][j]);
                if(Map[i][j] == 'x')
                    l[i][j] = 2;
                else
                    l[i][j] = 1;
                if(Map[i][j]=='r')
                    s = Pos(i,j,0);
				if(Map[i][j]=='a')
                    e = Pos(i,j,0);
            }
        }
        BFS();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao__hei__hei/article/details/81778927