Hdu 1007 Quoit Design

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 64492    Accepted Submission(s): 17082


 

Problem Description

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.

 

Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.

 

Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 

 

Sample Input

 

2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0

 

Sample Output

 

0.71 0.00 0.75

 

Author

大意就是找两个最近的点的距离的一半,不过我不会诶,分治思想,把各个点从中间分开,找到两段个点离中间值的最小值,然后合并他们,当然有可能出现最短点在同一边的可能,这时候你需要更新最短的距离。

在搜边的时候,如果这条边大于中间的边+当前最小值或者小于中间的边-当前最小值的话,不予讨论绝对不是最小的,

然后按y排序,更新最小值,如果大于ansbreak;

#include <iostream>
#include<cstdio>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
const int mod=7;
using namespace std;
struct node
{
    double x;
    double y;
}ac[100005];
int q[100005];
double dist(node a,node b)
{
    return sqrt((a.y-b.y)*(a.y-b.y)+(a.x-b.x)*(a.x-b.x));
}
bool cmpx(node a,node b)
{
    return a.x<b.x;
}
bool cmpy(int a,int b)
{
    return  ac[a].y<ac[b].y;
}
double find(int l,int r)
{
    if(l+1==r)
        return dist(ac[l],ac[r]);
        if(l+2==r)
            return min(dist(ac[l],ac[r]),min(dist(ac[l],ac[l+1]),dist(ac[l+1],ac[r])));
    int mid=(l+r)>>1;
    double  ans=min(find(l,mid),find(mid+1,r));
    int i,j,cnt=0;
    for(int i=l;i<=r;i++)
    {
        if(ac[i].x>=ac[mid].x-ans&&ac[i].x<=ac[mid].x+ans)
        {
            q[cnt++]=i;
        }
    }
    sort(q,q+cnt,cmpy);
    for(int i=0;i<cnt;i++)
    {
        for(int j=i+1;j<cnt;j++)
        {
            if(ac[q[j]].y-ac[q[i]].y>ans)break;
            ans=min(ans,dist(ac[q[j]],ac[q[i]]));
        }
    }
    return ans;
}
int main()
{
     ll t;
     while(scanf("%lld",&t)&&t!=0)
     {
         memset(q,0,sizeof(q));
         for(int i=0;i<t;i++)
         {
             scanf("%lf%lf",&ac[i].x,&ac[i].y);
         }
         sort(ac,ac+t,cmpx);
         printf("%.2lf\n",find(0,t-1)/2);
     }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41453511/article/details/81977994