ZOJ-Connect them(最小生成树)

Connect them

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cji, cii = 0, 1 <= i, j <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1

Hint

s:
A solution A is a line of p integers: a1, a2, ...ap.
Another solution B different from A is a line of q integers: b1, b2, ...bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= p, r <= q) such that ai = bi for all 0 < i < r and ar < br
OR
(2) p < q and ai = bi for all 0 < i <= p

题目链接:

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3204

题意描述:

给你n个点然后n*n条边,如果权值为0则说明这两点不通,问你能不能把所有的点连起来,如果能按字典序输出这些点,如果不能则输出-1,注意,在建立边的时候需要按字典序,还有在最后输出边的时候也要按字典序。

解题思路:

首先把这些边存到结构体里,然后排序用克鲁斯卡尔算法,把要建立的边存到另一个结构体里,然后再次排序,输出即可。

程序代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int inf=99999999;
struct data{
	int u;
	int v;
	int w;
}e[10010];
struct F{
	int a;
	int b;
}s[110];
int f[110];

int cmp(data x,data y);
int cmp1(F x,F y);
int getf(int u);
int merge(int u,int v);

int main()
{
	int n,T,i,j,m,t,count;
	scanf("%d",&T);
	while(T--)
	{
		t=1;
		count=0;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				scanf("%d",&m);
				e[t].u=i;
				e[t].v=j;
				e[t].w=m;
				if(m==0)
					e[t].w=inf;
				t++;
			}
		sort(e+1,e+t,cmp);
		for(i=1;i<=n;i++)
			f[i]=i;	
		for(i=1;i<t;i++)
		{
			if(merge(e[i].u,e[i].v)==1&&e[i].w<inf)
			{
				s[count].a=e[i].u;
				s[count].b=e[i].v;
				count++;
			}
			if(count==n-1)
				break;
		}	
		if(count!=n-1)
			printf("-1\n");
		else
		{
			sort(s,s+count,cmp1);
			for(i=0;i<count-1;i++)
				printf("%d %d ",s[i].a,s[i].b);
			printf("%d %d\n",s[count-1].a,s[count-1].b);
		}
	}
	return 0;
}
int cmp(data x,data y)
{
	if(x.w!=y.w)
		return x.w<y.w;
	else if(x.u!=y.u)
		return x.u<y.u;
	else
		return x.v<y.v;
}

int cmp1(F x,F y)
{
	if(x.a!=y.a)
		return x.a<y.a;
	return x.b<y.b;
}
int getf(int u)
{
	if(u==f[u])
		return u;
	f[u]=getf(f[u]);
	return f[u];
}

int merge(int u,int v)
{
	u=getf(u);
	v=getf(v);
	if(u!=v)
	{
		f[v]=u;
		return 1;
	}	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/84257802