ZOJ-Swordfish(最小生成树)

Swordfish

There exists a world within our world
A world beneath what we call cyberspace.
A world protected by firewalls,
passwords and the most advanced
security systems.
In this world we hide
our deepest secrets,
our most incriminating information,
and of course, a shole lot of money.
This is the world of Swordfish.
 

  We all remember that in the movie Swordfish, Gabriel broke into the World Bank Investors Group in West Los Angeles, to rob $9.5 billion. And he needed Stanley, the best hacker in the world, to help him break into the password protecting the bank system. Stanley's lovely daughter Holly was seized by Gabriel, so he had to work for him. But at the last moment, Stanley made some little trick in his hacker mission: he injected a trojan horse in the bank system, so the money would jump from one account to another account every 60 seconds, and would continue jumping in the next 10 years. Only Stanley knew when and where to get the money. If Gabriel killed Stanley, he would never get a single dollar. Stanley wanted Gabriel to release all these hostages and he would help him to find the money back.
  You who has watched the movie know that Gabriel at last got the money by threatening to hang Ginger to death. Why not Gabriel go get the money himself? Because these money keep jumping, and these accounts are scattered in different cities. In order to gather up these money Gabriel would need to build money transfering tunnels to connect all these cities. Surely it will be really expensive to construct such a transfering tunnel, so Gabriel wants to find out the minimal total length of the tunnel required to connect all these cites. Now he asks you to write a computer program to find out the minimal length. Since Gabriel will get caught at the end of it anyway, so you can go ahead and write the program without feeling guilty about helping a criminal.

Input:
The input contains several test cases. Each test case begins with a line contains only one integer N (0 <= N <=100), which indicates the number of cities you have to connect. The next N lines each contains two real numbers X and Y(-10000 <= X,Y <= 10000), which are the citie's Cartesian coordinates (to make the problem simple, we can assume that we live in a flat world). The input is terminated by a case with N=0 and you must not print any output for this case.

Output:
You need to help Gabriel calculate the minimal length of tunnel needed to connect all these cites. You can saftly assume that such a tunnel can be built directly from one city to another. For each of the input cases, the output shall consist of two lines: the first line contains "Case #n:", where n is the case number (starting from 1); and the next line contains "The minimal distance is: d", where d is the minimal distance, rounded to 2 decimal places. Output a blank line between two test cases.

Sample Input:

5
0 0
0 1
1 1
1 0
0.5 0.5
0


Sample Output:

Case #1:
The minimal distance is: 2.83

题目链接:

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1203

题意描述:

给你n个点的坐标,然后把这些点都连起来的最小生成树,在输出时样例之间用空行隔开。

解题思路:

把这些点存到数组里,然后两两比较得到两点之间的距离用prim模板即可。

程序代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
const double inf=99999999;

int n;
double x[110],y[110],e[110][110],dis[110];
bool book[110];
double prim();

int main()
{
	int i,j,count=0;
	double sum;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			scanf("%lf%lf",&x[i],&y[i]);
		for(i=1;i<=n;i++)
			for(j=i;j<=n;j++)
				e[i][j]=e[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])*1.0+1.0*(y[i]-y[j])*(y[i]-y[j]));

		sum=prim();
        if(count>0)
			printf("\n");
		printf("Case #%d:\nThe minimal distance is: %.2lf\n",++count,sum);
	}
	return 0;	
} 
double prim()
{
	int i,k,u;
	double mi,sum;
	for(i=1;i<=n;i++)
		dis[i]=e[1][i];
	memset(book,0,sizeof(book));
	book[1]=1;
	sum=0;
	for(k=1;k<n;k++)
	{
		mi=inf;
		for(i=1;i<=n;i++)
			if(book[i]==0&&dis[i]<mi)
			{
				mi=dis[i];
				u=i;
			}
		book[u]=1;
		sum+=dis[u];
		for(i=1;i<=n;i++)
			if(book[i]==0&&dis[i]>e[u][i])
				dis[i]=e[u][i];
	}
	return sum;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/84244308