PAT 甲级 1044 Shopping in Mars (前缀和)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: NNN (≤105\le 10^5≤10​5​​), the total number of diamonds on the chain, and MMM (≤108\le 10^8≤10​8​​), the amount that the customer has to pay. Then the next line contains NNN positive numbers D1⋯DND_1 \cdots D_ND​1​​⋯D​N​​ (Di≤103D_i\le 10^3D​i​​≤10​3​​ for all i=1,⋯,Ni=1, \cdots , Ni=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤\le≤ j such that DDDi + ... + DDDj = MMM. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤\le≤ j such that DDDi + ... + DDDj >M> M>M with (DDDi + ... + DDDj −M- M−M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

Code:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100000],sum[100000],q[100000];
int main()
{
	freopen("1044 Shopping in Mars.txt","r",stdin);
	memset(q,-1,sizeof(q));//-1 means 
	int n,m;
	cin>>n>>m;
	int a[n],sum[n];
	for(int i=0;i<n;i++)
		cin>>a[i];
	sum[0]=a[0];
	for(int i=1;i<n;i++)
		sum[i]=sum[i-1]+a[i];//prefix sum
	for(int i=0;i<n;i++){
		int j;
		for(j=i;j<n;j++)
			if(sum[j]-sum[i]+a[i]>=m){
				q[i]=j;
				break;
				/**
				q[i]=j means the sum from i to j is the smallest that bigger than M
				*/
			}
		if(j==n)break;
		/*
		cut the useless branches ,without it ,will run time out.
		if sum from i to the end is smaller than m ,the sum from i+1 to the end is the same.
		*/
	}		
	int minv=100000;
	for(int i=0;i<n;i++)
		if(q[i]!=-1){//if q[i]==-1,means  sum from i to the end is smaller than M
			if(sum[q[i]]-sum[i]+a[i]-m<minv)
				minv=sum[q[i]]-sum[i]+a[i]-m;
		}
		else
			break;
	for(int i=0;i<n;i++)
		if(sum[q[i]]-sum[i]+a[i]-m==minv)
			printf("%d-%d\n",i+1,q[i]+1);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/84304950