大数求余

题目描述

As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

输入

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

输出

For each test case, you have to ouput the result of A mod B.

样例输入

2 3
12 7
152455856554521 3250

样例输出

2
5
1521

分析:

此题重点考察大数取余。
我们会发现一个规律。
123456 mod 7
即:
https://blog.csdn.net/qq_32779119/article/details/79513480

#include"stdio.h"
#include"string.h"
int main()
{
    char a[1001];
    int B;
    int mod;
    int i,j,l;
    while(~scanf("%s %d",a,&B))
    {   mod=0;
        l=strlen(a);
        for(i=0;i<l;i++)
        {
            mod=(mod*10+(a[i]-'0'))%B;
        }
      printf("%d\n",mod);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_43506138/article/details/85042785