【笨方法学PAT】1069 The Black Hole of Numbers (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/83311821

一、题目

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

二、题目大意

给一个四位数,从大到小排序,从小到大排序,求差,判断结果是是否等于6174

三、考点

排序

四、注意

1、对0000特殊处理;

2、排序;

3、格式化输出。

五、代码

#include<iostream>
#include<algorithm>
using namespace std;
bool cmp(int a, int b) {
	return a > b;
}
int main() {
	//read
	int n;
	cin >> n;

	//solve
	int a[4],b[4];
	a[0] = b[0] = n / 1000;
	a[1] = b[1] = n / 100 % 10;
	a[2] = b[2] = n / 10 % 10;
	a[3] = b[3] = n % 10;
	sort(a, a + 4, cmp);
	sort(b, b + 4);

	//0000
	if (a[0] == a[1]&&a[0] == a[2] && a[0] == a[3]) {
		printf("%04d - %04d = 0000", n, n);
	}

	//others
	else {
		while (1) {
			int c = a[0] * 1000 + a[1] * 100 + a[2] * 10 + a[3];
			int d = b[0] * 1000 + b[1] * 100 + b[2] * 10 + b[3];
			n = c - d;
			printf("%04d - %04d = %04d\n", c, d, n);
			if (n == 6174)
				break;
			a[0] = b[0] = n / 1000;
			a[1] = b[1] = n / 100 % 10;
			a[2] = b[2] = n / 10 % 10;
			a[3] = b[3] = n % 10;
			sort(a, a + 4, cmp);
			sort(b, b + 4);
		}
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/83311821