1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

根据输入的数据判断没有的最小正整数

注意要判断输入数据的范围

 #include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,x;
    int a[100006]={0};
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>x;
        if(x>0&&x<100006)
            a[x]=1;
    }
    int num=0,ans;
    while(++num)
    {
        if(a[num]<1)
        {
            ans=num;
            break;
        }
    }
    cout<<ans;
}

猜你喜欢

转载自blog.csdn.net/x_zjudream/article/details/86503731