1144 The Missing Number (20分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7
#include<iostream>
#include<map>
using namespace std;


int main(){ 

    int n;
    cin >> n;
    map<int, bool> num;

    for(int i = 0; i < n; i++){
        int temp;
        scanf("%d", &temp);
        num[temp] = true;

    }

    for(int i = 1; i < 0x7fffffff; i++){
        if(num[i] != true){
            cout << i << endl;
            break;

        }
    }


    return 0;
}
发布了32 篇原创文章 · 获赞 0 · 访问量 436

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104070300