反转问题POJ_3276

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sumword_/article/details/66478507
Face The Right Way
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4768   Accepted: 2214

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer:  N 
Lines 2.. N+1: Line  i+1 contains a single character,  F or  B, indicating whether cow  i is facing forward or backward.

Output

Line 1: Two space-separated integers:  K and  M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

题意:

每次可以反转k个,目标都反转成F,问k为何值时反转次数最少。

思路:

遍历k,每次使用尺取法看能不能反转成功,反转需要几次,复杂度O(n2)

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f3
using namespace std;
int a[5050];
int n;
int panduan(int k){
    int b[5050];
    int ksum = 0;
    int total = 0;
    for(int i = 1; i <= n-k+1; i++){
        if((a[i]+ksum)%2){
            b[i] = 1;
            total++;
            ksum++;
        }
        else
            b[i] = 0;
        if(i-k+1 >= 1)ksum-=b[i-k+1];
    }
    int flag = 1;
    for(int i = n-k+2; i <= n; i++){
        if((ksum+a[i])%2)flag = 0;
        if(i-k+1 >= 1)ksum-=b[i-k+1];
    }
    if(flag)return total;
    else return INF;
}
int main(){
    while(scanf("%d",&n) == 1){
        for(int i = 1; i <= n; i++){
            char ch[2];
            scanf("%s",ch);
            if(ch[0] == 'B')a[i] = 1;
            else a[i] = 0;
        }
        int minn = panduan(1);
        int mink = 1;
        for(int i = 2; i <= n; i++){
            int temp = panduan(i);
            if(temp < minn){
                minn = temp;
                mink = i;
            }
        }
        cout << mink << " " << minn << endl;
    }
}


 

猜你喜欢

转载自blog.csdn.net/sumword_/article/details/66478507