poj3122 Pie

题目:
My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio> 
using namespace std;
#define PAI 3.14159265359//这里写成3.141592653就wa 
#define NIL 1e-6 
double a[10005];
int n;
int check(double k)//计算这种分发能最多分给多少人 
{
	int sum = 0;
	for(int i = 0;i < n;i++) sum += a[i] / k;
	return sum;
}
int main()
{
	int t,f;
	double l,r,mid,maxn;
	cin >> t;
	while(t--){
		cin >> n >> f;
		maxn = -1.0;
		memset(a,0,sizeof(a));
		for(int i = 0;i < n;i++){
			cin >> a[i];
			a[i] *= a[i];//计算出r^2
			maxn = max(maxn,a[i]);//找出最大r^2当成上界 
		}
		l = 0.0;//下界就是没人能分到pei 
		r = maxn; 
		while(r - l > NIL){
			mid = (l + r) / 2;
			int v = check(mid);
			if(v >= f + 1) l = mid; 
			else r = mid;
		}
		printf("%.4lf\n",r * PAI);
	}
	return 0;
}

题意:
告诉你有n个派和f和朋友,这些派都是圆柱体且高为1。现在告诉你这n个派的半径,要你把这n个派分给所有人(这里应该是f + 1,因为还要算上你自己),分给一个人的派必须是在一个派里切割得到的,不能几个派的体积加起来给一个人,现在要求能分到的最大体积。
思路:
刚开始看到这道题觉得很简单,这不就是第九届蓝桥杯分巧克力那道题的思路嘛!二分就可以了,但是我wa不知道多少次才AC了,因为这里精度的控制十分麻烦,首先定义Π不能写成3.141592653,一定要写成3.14159265359,虽然两者这么些样例上体现不出来,但是前者就是WA,我估计是精度出了问题。还有下界应该是0.0,而不是1.0,应为最差的状况就是没人能分到派。最后,就是二分的时候取等号一定要和>符号写在一起,不然精度又会出问题…

猜你喜欢

转载自blog.csdn.net/qq_41998938/article/details/88721684
pie