团体程序设计天梯赛-2017总决赛 L2-2 重排链表

版权声明:while (!success) try(); https://blog.csdn.net/qq_35850147/article/details/88754824

L2-2 重排链表 (25 分)

给定一个单链表 L​1​​→L​2​​→⋯→L​n−1​​→L​n​​,请编写程序将链表重新排列为 L​n​​→L​1​​→L​n−1​​→L​2​​→⋯。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。

输入格式:

每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤10​5​​)。结点的地址是5位非负整数,NULL地址用−1表示。

接下来有N行,每行格式为:

Address Data Next

其中Address是结点地址;Data是该结点保存的数据,为不超过10​5​​的正整数;Next是下一结点的地址。题目保证给出的链表上至少有两个结点。

输出格式:

对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

输出样例:

68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1

题解:

#include <bits/stdc++.h>

using namespace std;

struct Node
{
    int data, next;
} node[100000];
vector<int> v;
vector<int> u;

int main()
{
    int first, n, cnt = 0;
    scanf("%d%d", &first, &n);
    for (int i = 0; i < n; i++)
    {
        int add, data, next;
        scanf("%d%d%d", &add, &data, &next);
        node[add] = {data, next};
    }
    int p = first;
    while (p != -1)
    {
        cnt++;
        v.push_back(p);
        p = node[p].next;
    }
    for (int i = 0; i < cnt; i++)
    {
        int j = i & 1 ? i / 2 : cnt - 1 - i / 2;
        u.push_back(v[j]);
    }
    for (int i = 0; i < cnt; i++)
    {
        if (i)
            printf("%05d\n", u[i]);
        printf("%05d %d ", u[i], node[u[i]].data);
    }
    printf("-1\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/88754824