PATA1027 Colors in Mars

版权声明:版权归原作者CangyeChen所有,未经原作者允许不得转载本文内容,否则将视为侵权,转载或者引用本文内容请注明来源及原作者,对于不遵守此声明或者其他违法使用本文内容者,本人依法保留追究权等 https://blog.csdn.net/CANGYE0504/article/details/88836262

1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456
#include<cstdio>
#include<iostream>

using namespace std;

int main()
{
	const char a[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
	int r,g,b;
	scanf("%d%d%d%",&r,&g,&b);
	printf("#");
	printf("%c%c",a[r/13],a[r%13]);
	printf("%c%c",a[g/13],a[g%13]);
	printf("%c%c",a[b/13],a[b%13]);
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/CANGYE0504/article/details/88836262