字符模拟数字>>Time

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

Input

There are several test cases. 
Each case contains 4 integers in a line, separated by space. 
Proceed to the end of file.

Output

For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

    _  _  _ 
  | _||_ |_ 
  ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

Hint

The digits showed by the digital clock are as follows:
   _  _     _  _  _  _  _  _ 
 | _| _||_||_ |_   ||_||_|| |
 ||_  _|  | _||_|  ||_| _||_|

题意 数字钟用4位数字表示时间,每个数字用3*3个字符表示,现在给定当前时间,请告诉我们数字钟如何表示。

输入4个数字 输出用字符组成的形状

复制提示存起来 在输出就好了 把0忘了就过不了了

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char a1[35]= {"    _  _     _  _  _  _  _  _ "};
char a2[35]= {"  | _| _||_||_ |_   ||_||_|| |"};
char a3[35]= {"  ||_  _|  | _||_|  ||_| _||_|"};
void re(int a)
{
    if(a!=0)
    {
        for(int i=(a-1)*3; i<3+(a-1)*3; i++)
        {
            printf("%c",a1[i]);
        }
    }
    else
        printf(" _ ");
    return ;
}
void r2(int a)
{
    if(a!=0)
    {
        for(int i=(a-1)*3; i<3+(a-1)*3; i++)
        {
            printf("%c",a2[i]);
        }
    }

    else
        printf("| |");
}
void r3(int a)
{
    if(a!=0)
    {
        for(int i=(a-1)*3; i<3+(a-1)*3; i++)
        {
            printf("%c",a3[i]);
        }
    }

    else
        printf("|_|");
}
int main()
{
    int a,b,c,d;
    while(~scanf("%d %d %d %d",&a,&b,&c,&d))
    {
        re(a);
        re(b);
        re(c);
        re(d);
        printf("\n");
        r2(a);
        r2(b);
        r2(c);
        r2(d);
        printf("\n");
        r3(a);
        r3(b);
        r3(c);
        r3(d);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43372531/article/details/88880244