hud4135容斥原理模板

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N. 
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.

Input

The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).

Output

For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.

Sample Input

2
1 10 2
3 15 5

Sample Output

Case #1: 5
Case #2: 10


        
  

Hint

In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}. 
        
 
#include<iostream>
#include<cstdio>
#include<algorithm>
#define ll long long
#include<cstring>
#define maxn 1000005
#define ll long long
using namespace std;
ll  p[maxn];
int cnt;
int t;
ll a,b,n;
void fenjie(ll x)
{
    cnt=0;

    for(ll i=2;i*i<=x;i++)
    {
        if(x%i==0)
        {
            p[cnt++]=i;
            while(x%i==0)
                x/=i;

        }
    }
    if(x>1)
        p[cnt++]=x;
}
ll solve(ll x)
{
    ll sum=0,f,val;
    for(int i=1;i<(1<<cnt);i++)
    {
        f=0,val=1;
        for(int j=0;j<cnt;j++)
       {
           if(i&(1<<j))
        {
            f++;
            val*=p[j];

        }
    }

        if(f&1)
            sum+=x/val;
        else
            sum-=x/val;
    }
    return x-sum;

}
int main()
{
    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
        scanf("%lld%lld%lld",&a,&b,&n);
        fenjie(n);
        printf("Case #%d: %lld\n",w,solve(b)-solve(a-1));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89785788