HDU - 4135 Co-prime(容斥原理)

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
Sample Input
2
1 10 2
3 15 5
Sample Output
Case #1: 5
Case #2: 10

Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.


题意:给你一个区间[a,b],和一个数n,找出区间内与n互素的数的个数。
解题思路:找出[1,b]区间内与n互素的个数减去[1,a)区间内与n互素的个数。直接暴力找肯定超时,利用容斥原理n(A∪B∪C…)=n(A)+n(B)+n©…-n(A∩B)-n(A∩C)-n(B∩C)…+n(A∩B∩C)…找出区间内与n互素的个数,然后减去就剩下与n不互素的数的个数了。具体看代码,有注释。

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
typedef long long ll;
ll solve(ll r,ll n){
    vector<ll> p;
    //找出n的所有素因子
    for(ll i=2;i*i<=n;++i){
        if(n%i==0){
            p.push_back(i);
            while(n%i==0){
                n/=i;
            }
        }
    }
    if(n>1)
        p.push_back(n);
    ll sum=0;
    ll s=p.size();
    //二进制枚举加容斥原理找出与n不互素的数的个数
    for(ll i=1;i<(1<<s);i++){
        ll q=1;
        ll cnt=0;
        for(ll j=0;j<s;j++){
            if((1<<j)&i){
                q*=p[j];
                cnt++;
            }
        }
        if(cnt&1)
            sum+=r/q;
        else
            sum-=r/q;
    }
    return r-sum;//用r减去互素的个数就是不互素的个数
}
int main()
{
    int t;
    ll a,b,n;
    scanf("%d",&t);
    int c=1;
    while(t--){
        scanf("%lld%lld%lld",&a,&b,&n);
        //a~b中与n互质的个数等于(1~b)中与n互质的数减去(1~a)中与n互质的数
        ll ans=solve(b,n)-solve(a-1,n);
        printf("Case #%d: %lld\n",c++,ans);
    }
}

发布了36 篇原创文章 · 获赞 10 · 访问量 1910

猜你喜欢

转载自blog.csdn.net/weixin_44003265/article/details/103732477