HDU1232-畅通工程

版权声明:IT交流QQ群328880248,欢迎大家来一起学习一起交流~本篇文章未经同意请勿转载! https://blog.csdn.net/m0_38072683/article/details/88837943

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 76820    Accepted Submission(s): 40791

 

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。 

Sample Input

4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0

Sample Output

1 0 2 998

Hint

Hint

思路

如果有n个城镇,那么至少需要修n-1 条路。

用并查集,直接套模板。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int maxn = 1000 + 10;
int pre[maxn];
int ans = 0;

int find1(int x){
	if(pre[x] == x){
		return x;
	}
	return pre[x] = find1(pre[x]);
}
void join(int x, int y){
	int rootx = find1(x);
	int rooty = find1(y);
	if(rootx == rooty){
		return ;
	} else{
 		ans--;
		pre[rooty] = rootx;
 	}
}

int main(){
	int m,n,t1,t2;
	while(~scanf("%d",&n) && n){
		scanf("%d",&m);
		if(m == 0){
			printf("%d\n",--n);
			continue;
		}
		ans = n-1;
		for (int i = 1; i <= n; i++){
			pre[i] = i;
		}
		for (int i = 0; i < m; i++) {
			scanf("%d%d",&t1,&t2);
			join(t1,t2);
		}
		printf("%d\n", ans);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_38072683/article/details/88837943