每日编程(27)反转链表

1025 反转链表

给定一个常数 K 以及一个单链表 L,请编写程序将 L 中每 K 个结点反转。例如:给定 L 为 1→2→3→4→5→6,K 为 3,则输出应该为 3→2→1→6→5→4;如果 K 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 K 个元素不反转。

输入格式:

每个输入包含 1 个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 N (≤10^​5​​ )、以及正整数 K(≤N)即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。接下来有 N 行,每行格式为:

Address Data Next
其中 Address 是结点地址,Data 是该结点保存的整数数据,Next 是下一结点的地址。

输出格式:

对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

输出样例:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

class Node {
    int address;
    int data;
    int next;

    Node(int address, int data, int next) {
        this.address = address;
        this.data = data;
        this.next = next;
    }
}

//模拟链表(反转链表)
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int firstAddress = in.nextInt();
        int n = in.nextInt();
        int k = in.nextInt();
        Node[] list = new Node[100000];
        for (int i = 0; i < n; i++) {
            Node temp = new Node(in.nextInt(), in.nextInt(), in.nextInt());
            list[temp.address] = temp;  //可以重复,但是有序(存储的是引用)
        }
        in.close();
        List<Node> array = new ArrayList<>();
        link(list, firstAddress, array);
        reverse(array, k);
        for (int i = 0; i < array.size() - 1; i++) {
            System.out.printf("%05d %d %05d\n", array.get(i).address, array.get(i).data, array.get(i + 1).address);

        }
        int end = array.size() - 1;
        System.out.printf("%05d %d -1", array.get(end).address, array.get(end).data);


    }


    private static void reverse(List<Node> array, int k) {
        for (int i = 0; i + k <= array.size(); i += k) {
            for (int m = i + k - 1, n = i; m >= n; m--, n++) {
                Node temp = array.get(n);
                array.set(n, array.get(m));
                array.set(m, temp);
            }
        }

    }

    private static void link(Node[] list, int firstAddress, List<Node> array) {
        while (firstAddress != -1) {
            array.add(list[firstAddress]);
            firstAddress = list[firstAddress].next;
        }
    }


}


猜你喜欢

转载自blog.csdn.net/qq_41033299/article/details/89325767