(想起上次参观博物馆时问题的答案----“烦”)1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

给出三个十进制数,转化为十三进制输出(组合在一起),并在前面加#

Sample Input:

15 43 71

Sample Output:

#123456
#include<iostream>
using namespace std;
char radix[13] ={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
///最大的数是168,所以最大的余数为12取到C就行(题目也给说了。。。。。)
int main()
{
    int r, g, b;
    cin>>r>>g>>b;
    cout<<"#";
///最大168除两次就能除完(倒着输出的,可以用笔写一下)
    cout<<radix[r/13]<<radix[r%13];
    cout<<radix[g/13]<<radix[g%13];
    cout<<radix[b/13]<<radix[b%13];
}

猜你喜欢

转载自blog.csdn.net/qq_43813697/article/details/90340404