Py||Large integer multiplication

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/Lhw_666/article/details/102754640

题目描述
A large integer is an integer that far exceeds the range of integer types represented by the Python language, such as 10 to the power of 100. Please calculate the multiply result of two large integers and output the last digit of the result.
输入
The input consists of multiple lines, two large integers m and n per line, with a range of -10^100< m, n <10^100.
输出
Output the last digit of the multiply result of each pair of large integers, then wrap.
样例输入 Copy
1000000000000 1111111111111111111111111111111111
333333333 6565787654309090111
样例输出 Copy
0
3

while True:
    s=[str(i) for i in input().split()]
    s1=[]
    s2=[]
    j=0
    s1=[s[0]]
    s2=[s[1]]
    a=len(s1[0])
    b=len(s2[0])
    j=1
    for i in s1[0]:
        if j==a:
            x=int(i)
        j=j+1
    k=1
    for i in s2[0]:
        if k==b:
            y=int(i)
        k=k+1
    print((x*y)%10)

猜你喜欢

转载自blog.csdn.net/Lhw_666/article/details/102754640