hdu2955

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29413    Accepted Submission(s): 10774


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
 
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
 
  
2 4 6
 

Source

IDI Open 2009


题意很容易让你理解为  浮点概率和不超过给的 去找最大抢劫的钱就行

但是这肯定不是正解了  题意不是这个意思

题中给你的是被抓的概率  那么我们要求总的被抓的概率 肯定要反着求  先求能逃跑的概率

然后1 -  就得出了总的被抓的概率  

n最大为100  每家 银行的钱最多为100  那么把总钱数 看作背包  最大不超过10000

当 拿0的时候  逃跑的概率是1  

每次抢劫之后都要算  逃跑的概率乘积

#include<bits/stdc++.h>
using namespace std;
int n;
double p0;
int v[105];
double p[105];
double dp[10005]; 
//将总钱数看作背包   最大不超过1e4 
int main()
{
    int t;
    cin >> t;
    while(t --)
    {
        cin >> p0 >> n;
        int sum = 0;
        for(int i = 1;i <= n;i ++)
        {
        	cin >> v[i] >> p[i];
        	sum += v[i];
		}
		
		memset(dp,0,sizeof(dp));
		dp[0] = 1;  //不抢的时候逃跑的概率为1 
		for(int i = 1;i <= n;i ++)
		{
			for(int j = sum;j >= v[i];j --)
			dp[j] = max(dp[j],dp[j - v[i]] * (1 - p[i]));
		}
		for(int i = sum;i >= 0;i --)
		{
			if(dp[i] > (1 - p0))
			{
				cout << i << endl;
				break;
			}
		}
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80273432