Riding the Fences (USACO 3.3) 无向图欧拉通路/回路

Riding the Fences

Farmer John owns a large number of fences that must be repaired annually. He traverses the fences by riding a horse along each and every one of them (and nowhere else) and fixing the broken parts.

Farmer John is as lazy as the next farmer and hates to ride the same fence twice. Your program must read in a description of a network of fences and tell Farmer John a path to traverse each fence length exactly once, if possible. Farmer J can, if he wishes, start and finish at any fence intersection.

Every fence connects two fence intersections, which are numbered inclusively from 1 through 500 (though some farms have far fewer than 500 intersections). Any number of fences (>=1) can meet at a fence intersection. It is always possible to ride from any fence to any other fence (i.e., all fences are "connected").

Your program must output the path of intersections that, if interpreted as a base 500 number, would have the smallest magnitude.

There will always be at least one solution for each set of input data supplied to your program for testing.

PROGRAM NAME: fence

INPUT FORMAT

Line 1: The number of fences, F (1 <= F <= 1024)
Line 2..F+1: A pair of integers (1 <= i,j <= 500) that tell which pair of intersections this fence connects.

SAMPLE INPUT (file fence.in)

9
1 2
2 3
3 4
4 2
4 5
2 5
5 6
5 7
4 6

OUTPUT FORMAT

The output consists of F+1 lines, each containing a single integer. Print the number of the starting intersection on the first line, the next intersection's number on the next line, and so on, until the final intersection on the last line. There might be many possible answers to any given input set, but only one is ordered correctly.

SAMPLE OUTPUT (file fence.out)

1
2
3
4
2
5
4
6
5
7

两点注意:首先,没有跟你说点的序号一定是从1开始的两个点之间可能有不止一条道路。


/* 
ID: hysfwjr1
PROG: fence 
LANG: C++ 
*/
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <memory.h>
#define _DEBUG 0
#define MAXN 502
#define MAXE  1025

int fence[MAXN][MAXN];
int degree[MAXN];
int path[MAXE<<1];//路径节点
int pc=0;//路径节点计数

void Eulerian(int start){
	assert(start>=0);
	if(degree[start]>0){
		for(int i=1;i<=MAXN;i++){
			if(fence[start][i]>0){//可能不止一条边
				//去掉此路径
				degree[start]--;
				degree[i]--;
				fence[start][i]--;
				fence[i][start]--;
				Eulerian(i);
			}
		}		
	}
	path[pc++]=start;
}


int main(){
	freopen("fence.in","r",stdin);
#if _DEBUG==0
	freopen("fence.out","w",stdout);
#endif
	int e;
	int i;
	scanf("%d",&e);
	int u,v;
	for(i=0;i<e;i++){
		scanf("%d %d",&u,&v);
		degree[u]++;degree[v]++;
		fence[u][v]++;fence[v][u]++;
	}
	//寻找起点
	int start=-1;
	for(i=1;i<=MAXN;i++)//寻找第1个度不为0的点
		if(degree[i]!=0){
			start=i;
			break;
		}
	for(i=start;i<=MAXN;i++){//寻找第1个度为奇数的点
		if(degree[i]&0x1){
			start=i;
			break;
		}
	}
	Eulerian(start);
	for(i=pc-1;i>=0;i--){
		printf("%d\n",path[i]);
	}
	return 0;
}


发布了27 篇原创文章 · 获赞 4 · 访问量 5万+

猜你喜欢

转载自blog.csdn.net/hysfwjr/article/details/10260645