HDU - 1787 GCD Again

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a “Big Cattle”.
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
Sample Input
2
4
0
Sample Output
0
1

题意:给出一个n计算出一个M(0<M<N),并且n和M的最大公约数大于1

思路:就是让求小于n且不与n互质的数的个数。算出小于n且与n互质的数的个数(欧拉函数的值)然后用n减去这个值,注意这里M不能等于n,所以最后结果要减去1.(注意:这里的数据量太大,开不了这么大的数组,所以虽然是多组数据也不能预处理)

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int phi(int x)
{
    int ans = x;
    for(int i = 2; i*i <= x; i++)
    {
        if(x % i == 0)
        {
            ans = ans / i * (i-1);
            while(x % i == 0) x /= i;
        }
    }
    if(x > 1) ans = ans / x * (x-1);
    return ans;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
         int t;
         t=phi(n);
        printf("%d\n",n-t-1);
    }
}

发布了261 篇原创文章 · 获赞 14 · 访问量 7426

猜你喜欢

转载自blog.csdn.net/weixin_43244265/article/details/103996761