杭电oj刷题(2056)

Rectangles(计算两个矩形重合部分的面积大小)

题目描述:

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output

1.00 
56.25

通过答案:

#include<stdio.h>
void sort(double s[]){        //排序 
    int i,j;
    double temp;
    for(i=1;i<5;i++){
        for(j=4;j>i;j--){
            if(s[i]>s[j]){
                temp = s[i];
                s[i] = s[j];
                s[j] = temp;
            }
        }
    }

}

int main(){
    int i,j;
    double x[10],y[10],temp;
    while(scanf("%lf %lf %lf %lf %lf %lf %lf %lf",&x[1],&y[1],&x[2],&y[2],&x[3],&y[3],&x[4],&y[4])!=EOF){
    	//讨论4种情况 
        if((x[3]>x[1]&&x[4]>x[1]&&x[3]>x[2]&&x[4]>x[2])||(x[3]<x[1]&&x[4]<x[1]&&x[3]<x[2]&&x[4]<x[2])||(y[3]>y[1]&&y[4]>y[1]&&y[3]>y[2]&&y[4]>y[2])||(y[3]<y[1]&&y[4]<y[1]&&y[3]<y[2]&&y[4]<y[2])){
            printf("0.00\n");
        }else{
            sort(x);
            sort(y);
            printf("%.2lf\n",(x[3]-x[2])*(y[3]-y[2]));        //计算重合部分矩形 
        }
    }
}
发布了76 篇原创文章 · 获赞 3 · 访问量 1870

猜你喜欢

转载自blog.csdn.net/ZhangShaoYan111/article/details/104287462