HDU--1312--DFS

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

思路:DFS搜索;具体见代码;

#include<iostream>
#include<cstring>
using namespace std;
int n,m,ans,vis[21][21];//注意对应行数列数 
char a[21][21];
int dx[]={1,0,-1,0},dy[]={0,1,0,-1};
//int dx[]={1,-1,0,0},dy[]={0,0,1,-1};
//int dx[]={0,0,-1,1},dy[]={-1,1,0,0};//定义方向数组,三种方法都可以 
void dfs(int x,int y){
	a[x][y]='#';//水洼问题来源的思路,可以不写 
	//循环遍历四个方向
	vis[x][y]=1;
	for(int i=0;i<4;i++){
		int nx=x+dx[i];
		int ny=y+dy[i];
		if(nx>=0&&ny>=0&&nx<m&&ny<n&&a[nx][ny]=='.'&&!vis[nx][ny]){//!vis[nx][ny]表示对已经访问过的'.'不在访问 
			ans++;
			dfs(nx,ny);
		} 
	} 
	return;
}
int main(){
	while(1){
		scanf("%d%d",&n,&m); 
		if(n==0&&m==0)
			break;
		memset(a,0,sizeof(a));
		memset(vis,0,sizeof(vis));
		ans=0;
		for(int i=0;i<m;i++)
			scanf("%s",a[i]);
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				if(a[i][j]=='@'){//深搜
					dfs(i,j); 
					break;//找到起点就结束 
				} 
		cout<<ans+1<<endl;
	} 
} 
发布了150 篇原创文章 · 获赞 73 · 访问量 6568

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104353624