Robberies - 01背包

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
InputThe first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .OutputFor each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6

分析:

是01背包问题,但是不能超过的“重量”是小数,这时候我们可以换种表达方式:

把所有银行的总共钱数看做总价值,每个银行的钱数看做“价值”存到v数组里,被抓概率看做“重量”存到w数组里

dp[i]表示在偷了i这么多钱后,不被抓获的最大概率,sum表示被抓的最小概率

dp[j]=max(dp[j],dp[j-v[i]]*(1-w[i]));

然后用一个for循环,当dp[i]>(1-sum)则被抓

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
using namespace std;

double w[103],dp[10003];
int v[103];
int main(){
    int t,num,val;
    double sum;
    scanf("%d",&t);
    while(t--){
        scanf("%lf%d",&sum,&num);
        val=0;
        for(int i=0;i<num;i++){
            scanf("%d%lf",&v[i],&w[i]);
            val+=v[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=0;i<num;i++){
            for(int j=val;j>=v[i];j--){
                dp[j]=max(dp[j],dp[j-v[i]]*(1-w[i]));//表示偷价值为j的东西不被抓到的最大概率
            }
        }
        for(int i=val;i>=0;i--){
            if(dp[i]>(1-sum)){
                printf("%d\n",i);
                break;
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/80303285