POJ2676 Sudoku【DFS】

Sudoku
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 28548 Accepted: 13016 Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

Source

Southeastern Europe 2005

问题链接POJ2676 Sudoku
问题简述:(略)
问题分析
    数独问题,用DFS来解决,不解释。解题代码来自仙客传奇团队。
    数据规模小尚可使用DFS来解决,采用一定策略即按先试少的选择,时间上会快。采用跳舞链来解决,时间上会快。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2676 Sudoku */

#include <iostream>
#include <cstring>

using namespace std;

const int N9 = 9;
const int N = 10;
int map[N][N];
bool row[N][N], col[N][N], grid[N][N];


bool dfs(int r, int c)
{
    if(r == N9) return true;
    bool flag = false;
    if(map[r][c]) {
        if(c == 8) flag = dfs(r + 1, 0);
        else flag = dfs(r, c + 1);
        return flag;
    }
    int k = (r / 3) * 3 + c / 3;
    for(int i=1; i<=9; i++) {
        if(!row[r][i] && !col[c][i] && !grid[k][i]) {
            row[r][i] = col[c][i] = grid[k][i] = true;
            map[r][c] = i;
            if(c == 8) flag = dfs(r + 1, 0);
            else flag = dfs(r, c + 1);
            if(flag) return true;
            map[r][c] = 0;
            row[r][i] = col[c][i] = grid[k][i] = false;
        }
    }
    return false;
}

int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(NULL),
    std::cout.tie(NULL);

    int t;
    cin >> t;
    while(t--)	{
        memset(row,false,sizeof(row));
        memset(col,false,sizeof(col));
        memset(grid,false,sizeof(grid));

        for(int i = 0; i < N9; i++)
            for(int j = 0; j < N9; j++) {
                char ch;
                cin >> ch;
                map[i][j] = ch - '0';
                if(map[i][j]) {
                    row[i][map[i][j]] = true;
                    col[j][map[i][j]] = true;
                    grid[(i / 3) * 3 + j / 3][map[i][j]] = true;
                }
            }

        dfs(0, 0);

        for(int i = 0; i < N9; i++) {
            for(int j = 0; j < N9; j++)
                cout << map[i][j];
            cout << endl;
        }
    }

    return 0;
}
发布了2126 篇原创文章 · 获赞 2306 · 访问量 254万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/104491808