HDU--1217--伪floyd算法+思维--题目创新

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No

思路:构图+以下代码;真的是太强了...floyd算法--实际上就是动态规划;

for(int k=0;k<n;k++)
	    	for(int i=0;i<n;i++)
	    		for(int j=0;j<n;j++)
	    			cost[i][j]=max(cost[i][j],cost[i][k]*cost[k][j]);//注意此处为*;而floyd算法原来的表达方式是+; 

具体代码实现过程:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=50;
char bi[maxn][maxn]; 
double cost[maxn][maxn];
void init(){
	for(int i=0;i<maxn;i++)
		for(int j=0;j<maxn;j++)
			if(i==j)	cost[i][j]=1;
			else	cost[i][j]=0;
}
int main(){
	int n,m;
	int k=1;
	while(1){
		scanf("%d",&n);
		if(n==0)	break;
		init();
		for(int i=0;i<n;i++)
			scanf("%s",bi[i]);
		scanf("%d",&m);
		for(int i=0;i<m;i++){
	        double costa=0;
	        char s0[33],s1[33];
	        scanf("%s%lf%s",s0,&costa,s1);
	        int e1,e2;
	        for(int j=0;j<n;j++){
	        	if(strcmp(s0,bi[j])==0)
	            	e1=j;
	        	if(strcmp(s1,bi[j])==0)
	            	e2=j;
	        }
	        cost[e1][e2]=costa;
		}
	    for(int k=0;k<n;k++)
	    	for(int i=0;i<n;i++)
	    		for(int j=0;j<n;j++)
	    			cost[i][j]=max(cost[i][j],cost[i][k]*cost[k][j]);//注意此处为*;而floyd算法原来的表达方式是+; 
	    bool ok=true;
	    for(int i=0;i<n;i++)
	    	if(cost[i][i]>1.0){
				printf("Case %d: Yes\n",k++);
				ok=false; 
				break;
			}
		if(ok)	printf("Case %d: No\n",k++);
	} 
	return 0;
}
发布了170 篇原创文章 · 获赞 73 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104478189